Jane's Blog Tips, News, and Thoughts from the Jane Team

Security Update: New Browser Requirements

December 09, 2021

Hi Jane Community,

Abi here from the Jane Security team. Our team is responsible for ensuring the security of your data and the privacy of your patients. In fact, it’s what our team is dedicated to thinking about All. The. Time. 💙 That’s why we have updated our operating system & browser requirements to keep your data even more secure.

📣 Action! Check the list below to ensure your browser is up to date.

We recommend reviewing this list, and if you notice you aren’t meeting our updated browser requirements, you’ll need to update your browser. Here’s why ⤵️

Unsupported browsers & operating systems may result in issues accessing your Jane account or syncing calendar subscriptions. Our browser requirement update will occur on Wednesday, December 15th.

Good news. Chances are that you and your clients are already using a supported browser and operating system to run and book with Jane. If that is the case—hooray! You can rest assured knowing you are already doing your part in keeping your clinic and client data secure.

We felt that it was important to share this information in advance so that you have the opportunity to review the new requirements and make any updates needed. Surprises are great for birthday parties, but not so much for your everyday EHR software.

You might be wondering why we’re asking you to do this…

The Technical Stuff:

We have decided to deprecate requests made by TLS 1.0 and 1.1 due to the known vulnerabilities associated with these protocols.

To help understand TLS a little better, think of TLS as a bridge that allows you to merge onto the information highway. Older browsers, operating systems, and some applications will attempt to connect to the internet using versions of TLS with known vulnerabilities that are publicly available. Newer versions of TLS (1.2+) have patched these vulnerabilities right up. 💪

The Takeaway:

We have a responsibility for keeping your data secure. However, it is a bit of a group effort!

To do our part, we are no longer supporting TLS 1.0 and 1.1. We also want to encourage you to do your part by keeping your browsers and operating systems up to date.

By the way, that’s us below! Your friendly neighbourhood Security Team dedicated to you and your patients’ data. 💙

And as always, if you have any questions around privacy or security, we can be reached at privacy@jane.app as well as security@jane.app.

Stay Safe,

Abi on behalf of The Jane Security Team 🔒

Blog Posts